Programming 2D Games

The official forum for "Programming 2D Games" the book by: Charles Kelly

It is currently Fri Feb 28, 2020 9:05 am

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: ToolsVersion Error
PostPosted: Fri Aug 19, 2016 1:28 am 
Offline

Joined: Fri Aug 19, 2016 1:08 am
Posts: 2
Currently I'm trying to go through the book on my own and I've ran into a problem in chapter 3. I downloaded the sample DirectX Window code from the website but it won't compile with the following error:

Quote:
Project file contains ToolsVersion="12.0". This toolset may be unknown or missing, in which case you may be able to resolve this by installing the appropriate version of MSBuild, or the build may have been forced to a particular ToolsVersion for policy reasons. Treating the project as if it had ToolsVersion="4.0". For more information, please see http://go.microsoft.com/fwlink/?LinkId=291333. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\Microsoft.Cpp.Win32.Targets(518,5): error MSB8008: Specified platform toolset (v120) is not installed or invalid. Please make sure that a supported PlatformToolset value is selected.


I've went to the URL in the error message and it was no help. I am using Visual Studio 2010 on Windows 10. I installed the DirectX SDK (June 2010). I have also went through section 3.8.1 and set up all of the include and library paths, etc. I've been searching as much as I can but I can't seem to find a solution that works.

Any ideas, recommendations, or help would be very appreciated!


Top
 Profile  
Reply with quote  
 Post subject: Re: ToolsVersion Error
PostPosted: Fri Aug 19, 2016 9:57 am 
Offline
Site Admin
User avatar

Joined: Sat Jan 28, 2012 4:36 pm
Posts: 554
Open the solution file in Visual Studio.
Right click the project in the Solution Explorer window.
Select Properties.
Under Configuration Properties/General select Platform Toolset.
Select a different toolset version from the drop-down menu.

_________________
Professor Kelly


Top
 Profile  
Reply with quote  
 Post subject: Re: ToolsVersion Error
PostPosted: Fri Aug 19, 2016 6:49 pm 
Offline

Joined: Fri Aug 19, 2016 1:08 am
Posts: 2
Thank you for the reply Professor. I tried changing the Platform Toolset setting but it still gives me errors.

When changed to v100 it says "error TRK0005: Failed to locate: "CL.exe". The system cannot find the file specified."

When changed to v90 it says "error MSB8010: Specified platform toolset (v90) requires Visual Studio 2008."


Top
 Profile  
Reply with quote  
 Post subject: Re: ToolsVersion Error
PostPosted: Sat Aug 20, 2016 1:18 pm 
Offline
Site Admin
User avatar

Joined: Sat Jan 28, 2012 4:36 pm
Posts: 554
Try installing Visual Studio 2015 Community edition:

https://beta.visualstudio.com/vs/community/

I've been using it for several months and it works great. I can't tell any difference between the community version and the Pro version. I'm sure there are some differences but just nothing that has affected my work.

_________________
Professor Kelly


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group